74 ratings
  • 1
  • 2
  • 3
  • 4
  • 5
5 star 24
4 star 9
3 star 12
2 star 10
1 star 19
Compatible with
  • Android

Android Support Library v7 AppCompat 25.1.1.0

Xamarin Inc.

Provide backward-compatible versions of Android framework APIs.

v7 AppCompat Android Support Library

This library adds support for the Toolbar interface design pattern (including support for the ActionBar design pattern). This library includes support for material design user interface implementations.

Android Support Libraries

The Android Support Libraries are a set of code libraries that provide backward-compatible versions of Android framework APIs as well as features that are only available through the library APIs. Each Support Library is backward-compatible to a specific Android API level. This design means that your applications can use the libraries' features and still be compatible with devices running older versions of Android.

Including the Support Libraries in your Android project is considered a best practice for application developers, depending on the range of platform versions your app is targeting and the APIs that it uses. Using the features the libraries provide can help you improve the look of your application, increase performance and broaden the reach of your application to more users.

Write a Review

17 reviews

Luis Andrade rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

To anyone with problems instaling this library, here's how I got it working:

  • Create a new project;
  • First thing you do is install this library, and compile on instalation;
  • After that, go to manage nuget Packages, and in the installed tab, update the Android Support Library v7 AppCompat to the latest stable;
  • After that, clean your project and recompile;

This should o the trick.

Posted on: July 6 / Version: 25.1.1.0
arman espiar rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

why i can't download this library ? only add dlls to project and doesn't source download !

Posted on: June 4 / Version: 25.1.1.0
hasan çolakoglu rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

i can't add this app any body can help me ?

Posted on: May 20 / Version: 25.1.1.0
omid gh

hi ican't download this Component,Because when i added , then writed (incomplete)

Please Help me

Posted on: April 5 / Version: 25.1.1.0
Jamshaid Kamran rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

I am unable to add it this in the references. I even tried NugetPackage Manager Console but the problem still exists. Any Solution?

Posted on: March 26 / Version: 25.1.1.0
Ben rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

There is a big bug with this package:

"Android.Views.InflateException: Binary XML file line #1: Error inflating class android.support.v7.widget.Toolbar"

I cannot run my app on a android 22 device. Will you fix this?

Posted on: February 20 / Version: 25.1.1.0
Michal Mazur rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

Hi, Why I don't install version 24.2.1.0? In Soloution write Android.Support.Library v.7(Incomplete)

Version 23.4.0.1 it works. Sorry for my bad english ;)

Posted on: December 21, 2016 / Version: 24.2.1.0
Ranjith Nagiri

Hi, I am unable to find "Android Support Library v4" in component's list. Can you suggest the alternate component for that.

Posted on: December 14, 2016 / Version: 24.2.1.0
Marcio Ordonez

How can i use this zip file in my project?

Posted on: September 7, 2016 / Version: 23.4.0.1
VeswanthRaju Thokachichu

The reference not getting added to the application, it is showing an error the AppCompat namespace not found.

Posted on: August 29, 2016 / Version: 23.4.0.1
Ahmad Kharsah rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

Adding this component to the VS android project cause VS to crash when I try to open the layout file (*.axml) and if I remove it the project is happy .

Posted on: July 25, 2016 / Version: 23.1.1.1
Maikel de Laat

When can I expect a new release that uses AppCompat v7 23.1.0? It has a bug fix for the PagerTabStrip control: tab titles are not being shown on first display. This bug exists in 23.0 but not in previous versions. See https://code.google.com/p/android/issues/detail?id=183127

(i'm using package v23.0.1.3 from NuGet)

Posted on: October 20, 2015 / Version: 22.2.0.0
Cristiano Madeira

When I extend an activity with AppCompatActivity and try to call SetSupportActionBar method this error appears.

Member Android.Runtime.JNIEnv.CallVoidMethod not found.

Posted on: April 28, 2015 / Version: 21.0.3.0
Adriano Cordeiro

When version 22 will be released?

Posted on: March 31, 2015 / Version: 21.0.3.0
Misam Saki

Add support RTL for API < 17, please.

Posted on: March 16, 2015 / Version: 21.0.3.0
Petr Cecil rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

I really miss support in Xamarin.Forms you can't use AppCompat Material Themes there.

Posted on: January 28, 2015 / Version: 21.0.3.0
Daichi Kitagawa rates this with
  • 1
  • 2
  • 3
  • 4
  • 5

Nice binding.

The v7 support library should have it's ActionBarDrawerToggle class. That class in v4 support library is deprecated. https://developer.android.com/reference/android/support/v4/app/ActionBarDrawerToggle.html

update: The package of preview release 21.0.0-beta1 on NuGet contains ActionBarDrawerToggle class. Thanks.

Posted on: November 16, 2014 / Version: 20.0.0.1